GIMP Lomo Plugin

mF posted a Lomo plugin for the GIMP. His example images on flickr look good but I haven’t been able to get the script to run in GIMP 2.0, will try in GIMP 2.2 tonight.

script-fu: Error while executing
(load “/home/donncha/.gimp-2.0/scripts/lomo2.scm”)
ERROR: unbound variable (errobj script-fu-menu-register)

GIMP: Plug-In “script-fu”
(/usr/lib/gimp/2.0/plug-ins/script-fu)

attempted to install procedure “script_fu_lomo” in an invalid menu location.
Use either “<Toolbox>”, “<Image>”, “<Load>”, or “<Save>”

Update! Here is a GIMP Lomo plugin that works in GIMP 2.4!


You might also like

If you like this post then please subscribe to my full RSS feed. You can also click here to subscribe by email. There are also my fabulous photos to explore too!

11 thoughts on “GIMP Lomo Plugin


  1. Works in Gimp 2.2, yo. I must be using it on the wrong sort of pictures, though; it doesn’t look as Lomo as I was expecting.


  2. Just a hint on using the plugin, I developed it for Gimp 2.2, I’m not really sure what it involves to have it working on version 2.0 right now. Also to have a strong lomo effec use these settings: vignetting softness=1, Contrast=30, Saturation=30, Double Vignetting=TRUE. Cheers, mF

  3. Pingback: Holy Shmoly! :: GIMP Lomo Examples (1 comments.)

  4. Newbie here… How do I add the script into the folder? When I click the download link, it’s just text, so do I copy / paste it somewhere, or what? Thanks for helping me start understanding this stuff!

Leave a Reply

Loading Facebook Comments ...